HUIT Service Status Dashboard

Harvard community cannot log into Jabber
Incident Report for HUIT
Resolved
Huit teams have collaborated with Verizon to restore services.
Resolved
Posted May 30, 2020 - 18:07 EDT
Investigating
Members of the Harvard community who rely on Jabber for phone services are currently unable to log into Jabber. HUIT is working with Verizon to investigate and restore service.
Posted May 30, 2020 - 15:38 EDT
This incident affected: Telecommunication Systems.