Electrical Power Outage Notice for Swartz Hall, Andover Library, Center for the Study of World Religions, Jewett House, Carriage House, Rockefeller Hall, 38 Oxford St, OEB Greenhouse (4/15)
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 15, 2025 - 05:00 EDT
Scheduled
From Tuesday, April 15, 2025, at 5:00AM to Tuesday, April 15, 2025, at 6:30AM, there will be no normal electrical power to the following buildings.
Scheduled Electrical Out Times on Tuesday, April 15, 2025: 1. 5:00 AM - 5:30 AM: Swartz Hall, Andover Library, Center for the Study of World Religions, Jewett House, and Carriage House 2. 5:30 AM - 6:00 AM: Rockefeller Hall 3. 6:00 AM - 6:15 AM: 38 Oxford Street 4. 6:15 AM - 6:30 AM: OEB Greenhouse
The purpose of these scheduled outages is to move the main electrical service for these buildings from the CUP Station 8003 to the Northwest Station 8009.
Posted Apr 11, 2025 - 11:23 EDT
This scheduled maintenance affected: Utilities (Electricity).