HUIT Service Status Dashboard

Canvas SpeedGrader & Files Service Degradation
Incident Report for HUIT
Resolved
As of 12:54 our vendor declared the incident resolved. Canvas SpeedGrader Docviewer and Files performance has returned to normal.
Posted May 13, 2022 - 13:41 EDT
Monitoring
As of 11:45AM, our vendor has implemented a fix for the issues impacting Canvas SpeedGrader Docviewer and Files area. HUIT will continue to monitor alongside our vendor to ensure stability before declaring this incident resolved.
Posted May 13, 2022 - 13:04 EDT
Investigating
The Canvas SpeedGrader Docviewer is experiencing degraded performance. When trying to view an assignment submission, users receive an error "Service is currently unavailable. Try again later." The Files area is also affected. Files may not render for viewing, though they may upon reload.

Our vendor is currently investigating the issue and HUIT will provide updates as we receive more information.
Posted May 13, 2022 - 10:41 EDT
This incident affected: Canvas.