HUIT Service Status Dashboard

Office 365 and Two-Step/Duo Verification Issues
Incident Report for HUIT
Resolved
The incident is resolved, two-step verification has been removed for those users who had not previously had it turned on.
Posted Apr 18, 2020 - 15:55 EDT
Identified
The issue has been identified and HUIT is working on a remediation plan.
Posted Apr 18, 2020 - 14:19 EDT
Investigating
Users of Office 365 that have opted out of Two-Step/Duo authentication may now be getting prompted to use it. HUIT is investigating the issue.
Posted Apr 18, 2020 - 12:37 EDT
This incident affected: Email Services (Office 365 Email & Calendar).