HUIT Service Status Dashboard

Harvard Wireless Connectivity Intermittent Outage

Incident Report for HUIT

Monitoring

Harvard wireless network connectivity has been restored. We are continuing to monitor the network. If you continue to experience any issues, please contact the HUIT Service Desk at 617-495-7777 or ithelp@harvard.edu.
Posted Sep 03, 2026 - 14:37 EDT

Investigating

HUIT is investigating intermittent wireless network connectivity. Users may experience brief or inconsistent connections to Harvard Wi-Fi.
As a temporary workaround, please connect to the wired network using an Ethernet cable or docking station, if available.
We are working to resolve the issue and will provide updates as more information becomes available.
Posted Sep 03, 2026 - 13:58 EDT
This incident affects: Network Services (Wireless Networking).