HUIT Service Status Dashboard

Intermittent Issues with Harvard Phones
Incident Report for HUIT
Resolved
Harvard Phone services are back to normal.
Posted Mar 24, 2020 - 12:36 EDT
Monitoring
Verizon is indicating the issue is resolved - HUIT is testing.
Posted Mar 24, 2020 - 12:19 EDT
Investigating
HUIT is investigating Phones intermittent issues. Calls from outside the University are intermittently busy. Internal (Jabber) calls are working. Verizon is working to address the issues.
Posted Mar 24, 2020 - 11:37 EDT
This incident affected: Telecommunication Systems.