HUIT Service Status Dashboard

Outlook Online (OWA) experiencing authentication issues
Incident Report for HUIT
Resolved
This incident has been resolved after the vendor rolled back a change made earlier this afternoon.
Posted May 13, 2020 - 16:14 EDT
Identified
Microsoft has identified and is working to roll back a code change.
Posted May 13, 2020 - 15:05 EDT
Investigating
HUIT is currently investigating an issue in which some users are unable to connect to Exchange via Outlook Online (OWA), receiving a message about trouble signing in.
Posted May 13, 2020 - 13:47 EDT
This incident affected: Email Services (Office 365 Email & Calendar).