HUIT Service Status Dashboard

Critical vulnerability affecting Outlook on Windows
Incident Report for HUIT
Resolved
This incident has been resolved.
Posted Mar 22, 2023 - 13:00 EDT
Update
HUIT has completed patching the HUIT-managed computers impacted by the Microsoft security vulnerability and will continue to monitor our environment for any threat activity.

All Outlook desktop app users on Windows computers that are not managed by HUIT should check and update your version of Outlook to ensure your computer is protected: https://harvard.service-now.com/ithelp?id=kb_article&sys_id=73d8abe247e52110971198e8536d43a5

This will be the last Status Alert on this topic.
Posted Mar 21, 2023 - 15:14 EDT
Update
HUIT is continuing to monitor our environment for any threat activity and continuing to inform impacted Outlook users about updating the Outlook desktop apps to patch a critical security vulnerability.

On Tuesday, March 21st at 2:00 AM EST, HUIT will automatically apply the update to HUIT-managed computers that have not been updated.
When the update is applied, Microsoft 365 apps will automatically close and then restart. If a computer is asleep when the update is applied, it will receive the update when it is active again.

For computers that are not managed by HUIT or to update your computer before the automatic update please check and update your version of Outlook, https://harvard.service-now.com/ithelp?id=kb_article&sys_id=73d8abe247e52110971198e8536d43a5.

The update should take approximately five minutes.
Posted Mar 20, 2023 - 16:41 EDT
Update
HUIT has taken steps to inform impacted Outlook users and deployed a patch issued by Microsoft. We’ll continue to monitor our environment for any threat activity over the weekend and work with Harvard community members to ensure their accounts and systems are protected.

All Outlook desktop app users on Windows computers should check and update your version of Outlook to ensure that your computer is up-to-date and protected by following the instructions provided in this knowledge article - https://harvard.service-now.com/ithelp?id=kb_article&sys_id=73d8abe247e52110971198e8536d43a5
Posted Mar 17, 2023 - 10:38 EDT
Monitoring
On Tuesday, March 14, Microsoft reported a critical vulnerability affecting the Outlook desktop app on Windows. This issue is not specific to Harvard but affects all Outlook users on Windows computers.

Microsoft has included a patch for the vulnerability in its March 14 release. All Outlook desktop app users on Windows computers should check and update your version of Outlook to ensure that your computer is up-to-date and protected by following the instructions provided in this knowledge article - https://harvard.service-now.com/ithelp?id=kb_article&sys_id=73d8abe247e52110971198e8536d43a5

This message will be updated or removed on 3/16.
Posted Mar 16, 2023 - 11:48 EDT
This incident affected: Email Services (Office 365 Email & Calendar).