HUIT Service Status Dashboard

Potential issues accessing O365 mailboxes
Incident Report for HUIT
Resolved
The issue accessing some O365 mailboxes has been resolved.
Posted Apr 20, 2020 - 22:35 EDT
Investigating
HUIT has confirmed that some users may experience issues accessing O365 mailboxes.
Posted Apr 20, 2020 - 21:16 EDT
This incident affected: Email Services (Office 365 Email & Calendar).