HUIT Service Status Dashboard

Incident impacting Windows devices and servers
Incident Report for HUIT
Resolved
We have mitigated the impacts to Windows computers and servers caused by the global CrowdStrike incident. If you are still having problems, you can find self-service instructions at https://huit.harvard.edu/crowdstrike or you can contact the HUIT Service Desk for help (https://huit.harvard.edu/get-help).
Posted Jul 30, 2024 - 16:19 EDT
Update
We continue to work with the remaining users of Windows computers who are unable to access their devices. If you are still having problems, you can find self-service instructions at https://huit.harvard.edu/crowdstrike or you can contact the HUIT Service Desk for help (https://huit.harvard.edu/get-help).
Posted Jul 23, 2024 - 09:12 EDT
Update
HUIT and School IT departments continue to work with users of Windows computers who are unable to access their devices.

Users of Windows computers who are still experiencing issues can find self-service instructions at https://huit.harvard.edu/crowdstrike. If you need further assistance, please contact the HUIT Service Desk (https://huit.harvard.edu/get-help).
Posted Jul 22, 2024 - 14:34 EDT
Update
HUIT and School IT departments have been working throughout the day to remediate issues caused by today’s global CrowdStrike incident affecting Windows devices and servers. Critical University systems are operational and functioning as expected, and we continue to work with users of Windows computers who are unable to access their devices.

We will continue to monitor systems closely over the weekend and post further updates to the HUIT Status Dashboard (https://status.huit.harvard.edu).

Users of Windows computers who are still experiencing issues can find self-service instructions at https://huit.harvard.edu/crowdstrike. If you need further assistance, please contact the HUIT Service Desk (https://huit.harvard.edu/get-help). We sincerely apologize for the disruption caused by this global incident.
Posted Jul 19, 2024 - 16:14 EDT
Update
We continue to work to resolve the issue affecting Windows devices and servers.

We recommend users of Windows computers try rebooting their device multiple times (as many as 15 times). This has resolved the issues for some users, but not all.

HUIT has prepared additional advanced guidance on how to fix the issue by removing the corrupt file from Windows computers, however it is important to note this is a complicated, manual process with many steps: https://harvard.service-now.com/ithelp?id=kb_article&sys_id=c15d18bc47ab465010fc7a04716d4376

Printing on campus via Crimson Print is currently not available as a result of this issue. HUIT is working to restore access as soon as possible.

For further assistance, please contact the HUIT Service Desk (https://huit.harvard.edu/get-help) or your School’s local IT support (https://harvard.service-now.com/harvard-it-services).
Posted Jul 19, 2024 - 11:51 EDT
Update
HUIT and School IT departments are working to resolve the issue affecting Windows devices and servers. This is a global issue caused by a faulty update to the CrowdStrike cybersecurity software. CrowdStrike has confirmed that this is not the result of a security incident or cyberattack.

Microsoft is currently recommending that users of Windows computers who are experiencing blue screen error messages or are unable to access their device can try rebooting multiple times (as many as 15 times) which has resolved the issues for some users, but not all.

For further assistance, please contact the HUIT Service Desk (https://huit.harvard.edu/get-help) or your School’s local IT support (https://harvard.service-now.com/harvard-it-services).
Posted Jul 19, 2024 - 09:26 EDT
Identified
HUIT has confirmed that the issue affecting Windows devices and servers is a global issue caused by an update from Crowdstrike. Windows users are experiencing blue screen error messages, unexpected reboots of their devices, and an inability to access or use their systems. Due to the widespread impact of this issue, we expect several departments across Harvard will experience disruptions to work. We are actively working with Crowdstrike and other vendors to resolve.
Posted Jul 19, 2024 - 05:16 EDT
Investigating
Harvard is currently investigating widespread technical issues affecting Windows-based devices and servers on campus. At this time, users are experiencing blue screen error messages, unexpected reboots of their devices, and an inability to access or use their systems. Our technical teams are actively working with our vendors to diagnose and resolve the problems. We will provide an update on the situation at 5:00 am.
Posted Jul 19, 2024 - 03:18 EDT
This incident affected: Other Services.